Shortcake (Shortcode UI) – WordPress plugin 外掛推薦下載

點擊下載

Shortcake(Shortcode UI)

外掛Plugin描述

add_shortcode 一起使用,Shortcake提供用戶友好的界面用於向帖子添加短代碼,以及在內容編輯器中查看和編輯它。

安裝外掛Plugin後,您需要為您的短代碼註冊UI。如需靈感,請查看野生脆餅的例子

要報告錯誤或功能請求,請使用Github問題

運行測試

我們使用PHPunit和使用Jasmine的JavaScript測試PHP。

在本地運行測試

可以使用 grunt jasmine 運行Jasmine測試,也可以作為 grunt腳本任務的一部分運行。要更新Jasmine測試套件使用的核心WordPress文件,請運行 grunt updateJasmineCoreScripts --abspath =“/ path / to / wordpress-install”

屏幕截圖

如果沒有Shortcake,短代碼的UI最小。
但是使用Shortcake,TinyMCE將在TinyMCE視圖中呈現短代碼。
並添加用戶友好的UI以編輯短代碼內容和屬性。
通過“添加媒體”為帖子添加新的短代碼。

安裝

可以像任何其他WordPress外掛Plugin一樣安裝Shortcake。

完成後,您需要註冊代碼的UI

0.4.0中的新功能是將javascript函數附加到事件的能力屬性更新。動作掛鉤可用於根據另一個的值動態顯示或隱藏字段,或實現自定義驗證規則。

FAQ

如何將任意鍵/值對的UI註冊為短代碼屬性?

Shortcake不支持自定義鍵=>值對作為短代碼屬性,因為它不是一個很好的用戶體驗。

升級到Shortcake 0.7.x後,某些短代碼UI字段(選擇後,用戶選擇等)無法按預期工作。我能做什麼?

在0.7.0版本中,我們更新到Select2庫的最新分支,該分支在這些字段類型中提供增強的選擇字段。這會導致與插入舊版本Select2的外掛Plugin發生已知衝突。 (已知衝突的熱門外掛Plugin包括WooCommerce和Advanced Custom Fields Pro等。)

如果您發現與這些外掛Plugin發生衝突,可以設置一個標誌,以便在不同的命名空間中加載select2在wp-config.php中定義常量 SELECT2_NOCONFLICT (或在’init’掛鉤之前定義的任何地方。)

  define('SELECT2_NOCONFLICT',true);  

評論

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *

shares