Bad Behavior – WordPress plugin 外掛推薦下載

點擊下載

不良行為

外掛Plugin描述

歡迎使用全新的方式保存您的博客,論壇,留言簿,維基或
內容管理系統沒有鏈接垃圾郵件。 Bad Behavior是一種基於PHP的
解決方案,用於阻止鏈接垃圾郵件和提供垃圾郵件的機器人。

數以千計的大小網站,如SourceForge,GNOME,美國教育部等,以及更多,信任不良行為,以幫助減少
傳入鏈接垃圾郵件和惡意活動。

不良行為通過扮演守門人來補充其他鏈接垃圾郵件解決方案,

防止垃圾郵件發送者發送他們的垃圾,並且在很多情況下,從
首先閱讀您的網站。這可以減少網站的負載,
使您的網站日誌更加清晰,並有助於防止垃圾郵件發送者造成的拒絕服務
條件。

不良行為還通過以完全不同的,獨特的方式工作,超越了其他鏈接垃圾郵件解決方案。不良行為不僅僅是查看

潛在垃圾郵件的內容,而是分析交付方法以及垃圾郵件發送者正在使用的
軟件。通過這種方式,即使之前沒有人見過特定的垃圾郵件,不良行為也可以阻止垃圾郵件攻擊。

不良行為旨在與現有的垃圾郵件防護服務
協同工作,以提高其效率和效率。只要有可能,您應該

將其與更傳統的垃圾郵件防護服務結合使用。

Bad Behavior適用於或幾乎可以適用於任何基於PHP的Web
軟件包。對於WordPress,MediaWiki,

Drupal,ExpressionEngine和LifeType,本地可以使用不良行為,並且人們已成功使

使用Movable Type,phpBB和許多其他包。

在大多數平台上安裝和配置不良行為很簡單,只需幾分鐘即可完成
。在大多數情況下,根本不需要配置。只需

打開它,不再擔心垃圾郵件!

“不良行為”的核心是根據GNU Lesser General
公共許可證,版本3或您選擇的任何更高版本發布的免費軟件。

發行說明

錯誤行為2.2已知問題

錯誤行為2.2需要MySQL 5.0或更高版本以及PHP 5.2或更高版本。

CloudFlare用戶必須在“不良行為”的

設置中啟用“反向代理”選項。有關詳細信息,請參閱文檔。

錯誤行為無法保護MediaWiki上的內部緩存頁面。
只有表單提交才會受到保護。

從MediaWiki和WordPress版本2.0.19或更早版本升級
時,必須先手動從系統中刪除舊版本的錯誤行為

,然後再手動安裝新版本。其他平台不受

的影響。

WordPress上的錯誤行為需要3.1或更高版本。舊版
版本的用戶應在安裝不良行為之前升級WordPress。

在使用WP-Super Cache時,在WordPress上,必須在
WP-Super Cache的配置中啟用不良行為,以保護PHP Cached或Legacy

緩存頁面。錯誤行為無法保護mod_rewrite緩存(超級緩存)

頁面。

當與Spam Karma 2結合使用不良行為時,當Spam Karma 2顯示其內部生成的CAPTCHA時,您可能會看到PHP
警告。此

是Spam Karma 2中的設計問題。請與Spam Karma 2的作者聯繫以獲取

修復。

屏幕截圖

大多數時候,只有垃圾郵件發送者才會看到這一點。在極少數情況下,人類會在這裡提供一條出路。這可能涉及從用戶的計算機中刪除appleioussoftware,更改防火牆設置或其他簡單修正,這將立即再次授予訪問權限。

錯誤行為內置日誌查看器(WordPress)顯示請求被阻止的原因,並允許您單擊任何IP地址,用戶代理字符串或阻止過濾結果的原因。

安裝

警告

:如果要從2.0.x版本的“不良行為”升級,建議您刪除

安裝2.2.x版本之前系統中的舊版本,或者過時的文件可能會留下來。

警告

:如果要從1.xx版本的錯誤行為升級

,則必須將其從系統中完全刪除,並刪除其所有數據庫表,在安裝Bad Behavior 2.2.x或2.0.x之前。如果您從版本2.0.18或之前升級,則必須在升級之前刪除其所有文件
,但不需要刪除數據庫表。

錯誤行為旨在以最適合每個平台的
方式安裝在每個主機軟件上。通常

遵循為主機軟件安裝任何外掛Plugin或擴展

的一般說明。

在MediaWiki上,安裝擴展時需要向LocalSettings.php
添加第二行。您的LocalSettings.php應包含

以下內容:

`include_once(’includes / DatabaseFunctions.php’);
include(’./extensions/Bad-Behavior/bad-behavior-mediawiki.php’);

有關完整的文檔和安裝說明ns,請訪問
http://bad-behavior.ioerror.us/

評論

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *