SSL 不安全内容修复器 – WordPress plugin 外掛推薦下載

點擊下載

SSL不安全內容修復器

外掛Plugin描述

幫助您清除您的WordPress站點中有關HTTPS下不安全內容與混合內容的警告。通過安裝SSL不安全內容修復器(SSL不安全內容修復程序)來以最簡單的方式清除網站的不安全內容警告。其餘設定可以通過一個簡單的工具來進行檢測與診斷。

當您安裝SSL不安全內容修復器(SSL不安全內容修復程序)後,其默認配置將會被激活並自動啟用“簡單”等級的操作以執行一些基本的修復。您可以根據您的網站的需要選擇其他配置以獲得更全面的修復。

WordPress多站點配置下將會進入一個網絡配置頁面。此頁面內的配置可以作為網絡內全部站點的默認配置,從而使網絡管理員只需要默認配置的基礎上,根據不同網站的不同需求做出少量的對應改變。

訪問

SSL不安全內容修復器官方網站(中文)以獲取更多信息。

翻譯

感謝我們的翻譯者所做出的慷慨貢獻:

保加利亞語(bg_BG) –

保加利亞語翻譯團隊中文(簡體)(zh_CN) – 中文(簡體)翻譯團隊中語(加拿大)(en_CA) – 英語(加拿大)翻譯團隊英語(en_GB) – 英語(英國)翻譯團隊英語(en_ZA) – 英語(南非)翻譯團隊荷蘭語( nl_NL) – 荷蘭語翻譯團隊德語(de_DE) – 德語翻譯團隊法語(fr_FR) – 法語翻譯團隊意大利語(it_IT) – 意大利語翻譯團隊日語(ja) – 日語翻譯組俄羅斯語(ru_RU) – 俄羅斯語翻譯團隊西班牙語(es_ES) – 西班牙語翻譯團隊 如果你願意幫助我們翻譯這個外掛Plugin,請訪問

此網站。,並在註冊賬號後開始你的工作。

隱私

SSL不安全內容修復程序不會收集任何個人身份信息,也不會設置任何cookie。

安裝

本外掛Plugin可以通過WordPress管理界面自動安裝,或者下載.zip文件,解壓後上傳至/ wp-content / plugins /進行安裝。閱讀WordPress Codex上的

安裝外掛Plugin教程以獲取更多信息。通過WordPress的“外掛Plugin”菜單激活外掛Plugin。如果您的瀏覽器仍然報告不安全/混合內容,請閱讀

清理頁面

常見問題

我如何了解是什麼原因導致了不安全內容/混合內容警告的出現?

檢查您的瀏覽器的錯誤控制台

GoogleChrome的開發者工具中有一個

JavaScript控制台 FireFox有一個 Web控制台 Firebug 工具Internet Explorer有 F12工具控制台 Safari中有一個錯誤控制台(錯誤控制台) 注意:在你打開你的瀏覽器控制台之後,請刷新你的網頁,控制台將會試圖載入並列出其中的不安全內容,並記錄相關的警告。

為什麼沒有掛鎖? 有一個非常優秀的診斷HTTPS問題的在線工具。我從我的一些網站元素中收到了“不安全內容”警告。

你可能正在加載以“http:”開頭的URL所指向的內容(例如圖片)。刪除這一部分但保留斜杠,例如:

//www.example.com/image.png 。你的瀏覽器會加載這些資源,在你的頁面業已啟用HTTPS時使用該協議。更好的做法是用“https:”來替換“http:”,這樣便能保證網頁總是使用HTTPS協議來加載圖片,例如: https:// www。 example.com/image.png

如果你的頁面能在網頁瀏覽器之外的地方,諸如郵件或非網頁文檔中展示,那麼你應該使用HTTPS協議及以此開頭的鏈接(因為你擁有一張SSL證書)。你可以查閱

清除內容以獲得更多信息。我的網站部署於負載平衡器或反向代理之後

如果你的網部署於負載平衡器或反向代理之後,WordPress將不會檢測到HTTPS是否被啟用,你需要在

HTTPS檢測設置中選擇適當的選項。閱讀我的博客文章 WordPress is_ssl ()在某些負載均衡器後面不起作用以獲取更多信息。我收到了來自類似於jquery.js的基本WordPress腳本的警告

你的網站很有可能部署於反向代理之後 – 請閱讀常見問題中有關負載平衡器與反向代理器的相關解答,並在WordPress“工具”菜單中運行SSL測試。

我修改了檢測設置後無法登陸了

很有可能是因為你正在運行的其他外掛Plugin也在試圖修正HTTPS檢測。請將以下內容增加到你的wp-config.php文件中,將其添加至

ABSPATH 之上。接著你便可以在繼續配置之前將該外掛Plugin回滾至默認狀態。

 define('SSLFIX_PLUGIN_NO_HTTPS_DETECT',true);  在我的安全頁面上仍然收到“不安全內容”警告

請將其反饋到

支持論壇中,並且一定要包含指向有問題的頁面的鏈接。沒有附帶相關鏈接的帖子很有可能會被忽略。你們在兼容性問題中列出了我的外掛Plugin,但現在我已經修復了

太好了!請告訴我們你開發的是哪一款外掛Plugin以及應如何在該外掛Plugin的最新版本下進行測試,我會在下一個版本中去掉相關的“修復”標籤。

評論

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *

shares